Skip to main content

EndNote

Updates and Plugins

If you are prompted to install an update to your current version of EndNote (for example if you have EndNote x9.0 and are prompted to install EndNote x9.1) feel free to proceed to update to the latest version.

However, if you are prompted to connect to an EndNote online account or install any plugins (e.g. Kopernio) we recommend getting to know the basics of EndNote before adding layers of complexity. You can choose the x or cancel option to close these prompts.

Welcome to Endnote

SCU SCU Library on Facebook SCU Library on Twitter SCU Library Instagram SCU Library SoundCloud